Building, Deploying, and Updating an Image on HP Commercial PCs

Table of contents

Terms and definitions................................................................................................................................................................... 3
Overview.................................................................................................................................................................................. 3
Requirements........................................................................................................................................................................... 3
Operating system deployment .................................................................................................................................................. 4
  Bare metal deployment with driver pack via HP MIK ........................................................................................................ 4
  Importing HP Driver Packs into SCCM ......................................................................................................................... 4
  Importing an HP WinPE Driver Pack and creating boot images .................................................................................. 6
Importing HP Driver Pack without using HP MIK ........................................................................................................... 8
  Downloading HP Driver Packs ............................................................................................................................................ 8
  Creating and importing HP Driver Packs ................................................................................................................... 8
  Downloading and Importing HP WinPE Driver Packs .................................................................................................. 10
  Creating an operating-system-deployment task sequence ........................................................................................ 10
Configuring task sequence steps for your environment ................................................................................................ 12
BitLocker task .......................................................................................................................................................................... 15
  Using HP BIOS Configuration Utility to prepare the BIOS for BitLocker enablement ........................................... 15
  Editing a task sequence to modify BIOS settings and disable or enable BitLocker ............................................. 17
HP update deployment .............................................................................................................................................................. 19
  Deploying HP updates via HP Client Catalog and Microsoft SCCM 2012 or higher .................................................. 19
    Configuration Manager .................................................................................................................................................... 20
    Importing and publishing third-party updates ........................................................................................................ 20
    Publishing HP updates to WSUS .................................................................................................................................. 23
    Synchronizing software updates from WSUS to Configuration Manager 2012 .................................................... 24
    Deploying an HP software update from Configuration Manager ................................................................................ 24
  Deploying HP updates using HP SDM and HP SSM .......................................................................................................... 25
    Creating an SSM batch file ................................................................................................................................................. 25
    Deploying HP updates using HP SDM and HP SSM with SCCM .................................................................................. 26
    Deploying HP updates using HP SDM and HP SSM with no management console .............................................. 31
Appendix A: Installing the HP MIK for Configuration Manager 2012 R2 or higher ...................................................... 32
Appendix B: Using HP SDM .................................................................................................................................................. 33
  Installing and setting up HP SDM .................................................................................................................................... 33
  Downloading required SoftPaqs ........................................................................................................................................... 33
**Terms and definitions**

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>SCCM</td>
<td>Microsoft® System Center Configuration Manager</td>
</tr>
<tr>
<td>WSUS</td>
<td>Windows® Server Update Services</td>
</tr>
<tr>
<td>SCUP</td>
<td>Microsoft System Center Updates Publisher</td>
</tr>
<tr>
<td>Windows ADK</td>
<td>Windows Assessment and Deployment Kit</td>
</tr>
<tr>
<td>Windows AIK</td>
<td>Windows Automated Installation Kit</td>
</tr>
<tr>
<td>Windows PE</td>
<td>Window Pre-Installation Environment</td>
</tr>
<tr>
<td>HP MIK</td>
<td>HP Manageability Integration Kit for SCCM</td>
</tr>
<tr>
<td>OSD</td>
<td>Operating System Deployment</td>
</tr>
<tr>
<td>HP SDM</td>
<td>HP SoftPaq Download Manager</td>
</tr>
<tr>
<td>HP SSM</td>
<td>HP System Software Manager</td>
</tr>
<tr>
<td>HP BCU</td>
<td>HP BIOS Configuration Utility</td>
</tr>
<tr>
<td>OS</td>
<td>Operating system</td>
</tr>
<tr>
<td>PXE</td>
<td>Pre-boot Execution Environment</td>
</tr>
<tr>
<td>SoftPaq</td>
<td>Format used to deliver software to the end-users. It is self-extracting and (optionally) auto-executing.</td>
</tr>
</tbody>
</table>

**Overview**

The purpose of this document is to detail the specific steps required to build a common HP image across our HP Elite and Pro series products using Microsoft System Center Configuration Manager (SCCM) 2012 R2 or higher and to provide common methods for deploying HP updates. This document assumes that you have a reasonably high level of familiarity with the standard SCCM deployment process.

**Requirements**

How you structure or configure SCCM is a matter of preference, and the criteria differs from organization to organization. This document does not include instructions on how to install and configure SCCM. HP recommends installing and configuring SCCM before integrating HP Manageability Integration Kit (HP MIK) and other HP tools.

**Note**

SCCM and Windows Deployment Services (WDS) must be properly configured for use with both the operating system deployment (OSD) and Preboot Execution Environment (PXE) function. For more information of Microsoft System Center Configuration Manager, go to [http://www.microsoft.com/systemcenter](http://www.microsoft.com/systemcenter).
Operating system deployment

Bare metal deployment with driver pack via HP MIK
Importing HP Driver Packs into SCCM

1. If HP MIK is not installed, download and install it. See Appendix A: Installing the HP MIK for SCCM 2012 R2 or higher.
2. In the Configuration Manager console, select Software Library.
3. In the Software Library workspace, expand Overview, and then click Operating Systems.
4. Right-click Driver Packages and select Download and Import HP Client Driver Packs.

Note

If you want to create a custom driver pack, select Create and Import HP Client Driver Pack. Browse to select an operating system and HP product(s), and choose specific driver(s) to import.
If you have previously downloaded this driver pack, select Import Downloaded HP Client Driver Pack. Browse to location that you want to download the driver pack to, and then follow the on-screen instruction to complete the importation of the driver pack.

5. Select an operating system from the Operating system list. The Available products field displays the products that support driver packs.
6. Optionally, enter keywords into the HP product name field and press Enter to filter the list of available driver packs.
7. Select the driver packs for the targeted operating system deployment, and then click the right-arrow button to add the products to the Selected products list. The driver packs associated with the selected products are displayed in the Available driver packs list.
8. Optionally, select distribution points to assign the imported driver packs to specific destinations. However, cloud distribution points are not supported.
9. Optionally, change the default location for Configuration Manager to save the drivers and driver package. Be sure that the specified location has sufficient rights to be accessed by all necessary user accounts. The location is saved automatically, per user, after a successful importation.
10. If the driver pack download and importation process much stop when an error is encountered, clear the Continue on errors checkbox. By default, this box is checked. If multiple driver packs are selected, the process continues to the next selected driver pack if the download and importation of the current driver pack fails.
11. Select **Download and Import** to start the driver pack download and importation process.

**Note**

Only use the **Reset Form** button to clear all current selections.

12. During the download and importation process, a dialog displays the current operation and progress. This process downloads the selected driver packs and then imports them into Configuration Manager. If one or more selected driver packs already exist in Configuration Manager, the process prompts the user to skip or overwrite the existing driver packs.

After the process is complete, a summary of the import status of each driver pack is displayed. Click on the summary or detailed log files for more information about the status of the driver pack importation.

**Note**

These logs can be found on SCCM server at

\c:\\Users\administrator.domain\appData\Local\Temp\hpclient\.
13. The imported driver packs are available in **Driver Packages > HP Client Driver Packages**. The drivers are imported into the base driver folders and then given categories that match the driver package name.

Before the imported driver packs can be used in a task sequence, they need to be pushed out to the distribution points. If no distribution points were selected in the download and import dialog or if additional distribution points are needed, select each imported driver pack, select **Distribute Content**, and then follow the on-screen instructions to push the driver packs to the desired distribution points.

**Note**
This process requires a continuous Internet connection to [ftp.hp.com](ftp.hp.com). If the driver pack information cannot be retrieved from ftp.hp.com on the device by the Configuration Manager console, open a browser session to verify your Internet connection, and then try to complete the process again.

If there is no Internet connection to ftp.hp.com on the device with the Configuration Manager console, obtain the HP driver packs via one of the methods in the section Importing HP Driver Pack without using HP MIK, and use the **Import Downloaded Driver Pack** menu item instead.

Because you tried to import the driver and appended a new category to it, you might have the duplicate driver entries in the driver library.

**Importing an HP WinPE Driver Pack and creating boot images**

1. Download the HP WinPE driver pack and save it on a shared location.
2. In the Configuration Manager console, select **Software Library**.
3. In the **Software Library** workspace, expand **Overview**, and then click **Operating Systems**.
4. Right-click **Boot Images**, and then select **Create HP Client Boot Image**.

**Note**
Each version of Microsoft System Center 2012 Configuration Manager supports a specific version of Windows AIK or Windows ADK. You can service, or customize, boot images from a Configuration Manager console when they are based on a Windows PE version from the supported version of Windows AIK or Windows ADK. Because of this limitation, HP CIK Create Boot Image provides limited support.

Configuration Manager uses Windows ADK, particular DISM.exe, to inject drivers to a boot image. HP MIK leverages this DISM method to inject specific HP NIC, Storage, and USB 3.0 drivers contained in the HP WinPE Driver Pack into the base boot image. Be sure that you are fully aware that if you use your customized image as a base boot image; the resulting HP boot image has all modifications and customizations of your base boot image.

5. In **Create HP Client Boot Image(s)**, click **Browse** to select the downloaded HP WinPE driver pack SoftPaq targeted for importation.
6. Optionally, change the default locations for Configuration Manager to save the drivers, the driver package, and the boot images. Be sure that the specified locations have sufficient rights to be accessed by all necessary user accounts.
7. To create boot images with drivers from the selected HP WinPE driver pack, select the base boot images to use, and then select **Create**.
8. Optionally, select distribution points to assign the boot images to a specific destination. However, cloud distribution points are not supported.

**Note**
If you attempt to import an unsupported WinPE driver pack, HP MIK does not display any base boot images based on the Windows ADK version installing on the server.

For more details on operating system versions supported by HP MIK, WinPE, ConfigMgr, and Windows ADK, see the white paper *Microsoft ConfigMrg and HP CIK - Supported Combinations & Features*.

9. Optionally, change the default location for Configuration Manager to save the drivers and driver package.

10. Depending on the architecture of the base image, x86 and/or x64 images are created. HP WinPE driver packs contain drivers for both 32- and 64-bit boot images.

After the process is complete, the new boot images are available in **Boot Images > HP Client Boot Images**.
Importing HP Driver Pack without using HP MIK

Downloading HP Driver Packs
There are several ways to download HP Driver Packs without using HP MIK:

- Via HP SDM. See Appendix B: Using HP SDM.
- Via HP Client Management Solutions.

To download HP Driver Packs via HP Client Management Solutions:

2. Select HP CMS Download Library.
3. Under HP Drive Pack Matrix, select the link to the 32-bit or 64-bit driver packs, depending on the target operating systems.
4. Locate the appropriate product types, model names, and operating systems of the target devices, and then download the appropriate driver packs for the target operating systems.

Creating and importing HP Driver Packs
HP Driver Packs are self-extracting executable files that generally contain all or most of the drivers need for a bare-metal deployment. You need to extract these self-extracting executables before creating and importing them.

Creating a driver package

1. In the Configuration Manager console, click Software Library.
2. In the Software Library workspace, expand Overview, and then click Operating Systems.
3. To start the New Driver Pack Wizard, right-click Driver Packages, and then click Create Driver Package.

4. In the Name field, enter a descriptive name for the driver package.
5. In the Description box, enter an optional description for the driver package that provides information about the contents or the purpose of the driver package.
6. In the Driver packages Source field, enter the path for an empty source folder for the driver packages in Universal Naming Convention (UNC) format.
   – or –
   Click Browse to open the Select Folder dialog, and then browse to the folder that you want to use as the source for this driver package. Each driver package must use a unique folder.

   **Note**
   The new driver package does not contain any drivers. The next step is to add drivers to the package.

Importing device drivers into the driver packages

1. In the Configuration Manager console, click Software Library.
2. In the Software Library workspace, expand Overview, and then click Operating Systems.
3. Right-click Drivers, and then click Import Driver.
4. The Import New Driver Wizard is displayed. In the **Import New Driver Source** field, enter the path to the source folder of the extracted HP Driver Packs in Universal Naming Convention (UNC) format.
   – or –
   Click **Browse** to open the Select Folder dialog box, browse to the folder that contains the extracted HP Driver Packs, and then click **Next**.

5. On the Driver Details page, click **Next**.

6. On the Add Driver to Packages page, select the package created in Creating a driver package.

![Import New Driver Wizard](image)

7. On the Add Driver to Boot Images page, leave the setting as default and click **Next**.

**Important:**
Do not add drivers from an HP Driver Package to your boot image. HP has WinPE specific driver packages that are covered in Importing an HP WinPE Driver Pack and creating boot images.

8. On the Completion page, confirmation that the new drivers were imported successfully is displayed.

9. Click **Close** to exit the wizard.

![Import New Driver Wizard Completion](image)
**Distributing the driver packages**

1. In the Configuration Manager console, expand **Software Library > Overview > Operating Systems > Driver Packages**.
2. Right-click the newly created driver packages and select **Distribute Content**.
3. Select a distribution point.
4. If the distribution is successful, a notification appears that the wizard complete successfully.

**Downloading and Importing HP WinPE Driver Packs**

**Downloading HP WinPE Driver Packs**

2. Select **HP CMS Download Library**.
3. Browse to **HP WinPE Driver Pack**, and then select the 32- and 64-bit link.
4. Download the appropriate version for your WinPE environment.

**Note**

See [Microsoft ConfigMgr and HP CIK Supported Combination and Features](#) for more information.

5. Extract the HP WinPE SoftPaq to shared location.

**Importing HP WinPE Driver Packs into a boot image**

1. In the Configuration Manager console, click **Software Library**.
2. In the Software Library workspace, expand **Overview**, and then click **Operating Systems**.
3. Right-click **Drivers** and then click **Import Driver**.
4. The Import New Driver Wizard is displayed. Browse to the extracted HP WinPE Driver Packs, and then select them.

**Note**

HP WinPE driver packs include both the 64- and 32-bit drivers into one pack. HP recommends importing them separately with categories associated to the driver architecture; that is, WinPE 5.0 x86 or winPE 5.0 x64.

5. On the Driver Details page, verify that the drivers to be imported into the boot images are selected, and then click **Next**.
6. On the Apply Driver to Package page, do not select any packages, and then click **Next**.
7. On the Add Driver to Boot Image page, select the appropriate base boot image.
8. Optionally, select the **Update Distribution point when finished** option.

9. On the Completion page, there is a confirmation when the drivers are imported correctly.

**Creating an operating-system-deployment task sequence**

1. In the Configuration Manager console, select **Software Library**.
2. In the Software Library workspace, expand **Overview**, and then click **Operating Systems**.
3. Right-click **Task Sequences**, and then select **Create HP Client Deployment Task Sequence**.
4. Select a template from the Task Sequence Template drop-down box. The following example shows how to reference HP Tools to aid with the deployment process.

5. Fill in the fields as instructed.
   A. Select a parent task sequence template.
   B. Enter a name for the new template.
   C. Enter the Account name and Password for an account with administrator-level credentials.
   D. Select Use an OS WIM, and then select the Operating system package to use.

6. Select Create to create a basic, bare-metal deployment task sequence for HP client systems. A message box displays confirmation of the successful creation of the task sequence.
Configuring task sequence steps for your environment

1. Right-click the task sequence created in Creating an operating-system-deployment task sequence, and then select **Edit**.

2. Click the **Apply Device Drivers** step in the task and delete it. HP recommends apply driver package to handle drivers in this task.

3. Click **Add > Drivers > Apply Driver Package**.

4. Optionally, in the **Name** box, modify the name of the driver package.

   **Note**
   In the task sequence, move this step to directly after the **Apply Operating System** step.
   If you are deploying the same task sequence to multiple HP platforms, repeat steps 3 and 4 for each platform.

5. Browse to the driver package created earlier, and then select it.

6. On each HP system there is a unique identifier called a system board ID, or SYSID for short. The SYSID never changes for any specific model and can be relied upon for driver insertion. You can find this value via a WMI query, because this value is used by HP driver tools for system detection. HP recommends that you use this value to control driver injection and package installation.

   To perform a WMI query to find the SYSID:
   A. On the **Apply Drivers Task** step, open the **Options** tab. Select **Add Condition**, and then select **If statement**.
B. On the If Statement Properties page, click **Any Condition**, and then select **OK**.

C. Click the If any statement you just added, and then click **Add Condition > Query WMI**.

D. Open the CVA file from the driver pack that you imported. The CVA file within an HP SoftPaq is a text file similar to a Microsoft .ini file.

E. Find the SYSIDs of all systems supported by the driver pack.

F. Enter this **WMI Query** for each SYSID you found that is in your IT environment.
   For example, a SYSID of **1993** can be tested for during deployment using the following WMI Query:
   ```wmi
   SELECT * FROM Win32_BaseBoard WHERE Product = "1993"
   ```

G. Click **Test query**. If successful, a valid syntax confirmation message appears.

**Note**
If a valid syntax is not reported, your task sequence will fail because the task sequence engine cannot evaluate the statement properly.

H. Add a WMI query for each SYSID in your environment.
**Note**
All the WMI queries should be rooted to the If any statement.

I. Repeat this process with for each driver pack, so that every driver pack contains every WMI query needed to support the platforms in your IT environment.

7. You can now deploy the task sequence.
BitLocker task

Using HP BIOS Configuration Utility to prepare the BIOS for BitLocker enablement

1. If you have HP MIK installed, right-click the **HP Client BIOS Configuration Utility** package in the **Software Library** and select **Properties**.

2. Click the **Data Source** tab. Do not click the network location.

3. Browse to the location of the source package, and then copy the `BiosConfigUtility64.exe` file to a USB drive.

**Note**

Sometimes the operating system deployment folder is not properly shared and permissions need to be fixed on this folder before you can browse it and copy files into it.

4. Insert the USB drive into the client system you are working with and run the following command, where `D:` is the USB drive:

   ```
   D:\BiosConfigUtility64.exe /get:uniquename.txt
   ```

   HP recommends that you name the configuration file `<modelname>.txt` so that a small form factor desktop HP 6300 would be `6300sff.txt` or an HP Revolve G2 would be `810G2.txt`.

5. Verify that the configuration file was created in the root directory of the USB drive.

6. Open the configuration file and delete any settings that you do not intend to change.
7. The following settings are required to allow BitLocker to be enabled in your SCCM task. The following example uses the HP 810 G2 used as an example.

**Note**
If you are a first-time BCU user, see the [HP BIOS Configuration Utility (BCU) User Guide](#) for details on how BCU works and command-line usage.

The settings can be slightly different for each platform family, and as such HP recommends that you create a configuration file for each platform, and that testing effort is put into verifying cross platform compatibility of a given configuration file. Product families of the same generation can generally share a configuration file, but always test any configuration files you intend to deploy.

A. Set **TPM Reset to Factory Defaults** to **No**.
B. Set **Reset of TPM from OS** to **Enable**.
C. Set **OS Management of TPM** to **Enable**.
D. Set **Activate TPM On Next Boot** to **Enable**.
E. Set **TPM Device** to **Available**.
F. Set **TPM Activation Policy** to **No prompts**.

8. Save this file in the **Config** folder in the BCU package source location.
9. Enter the BIOS Admin password is required to enable the TPM settings.
10. The **P@ssw0rd1234.bin** file needs to be in the BCU folder as well.

For setup information for SSM and instructions that detail the creation of the password.bin file, see Appendix C: Installing and configuring HP SSM.

11. In the Software Library, right-click the **HP Client BIOS Configuration Utility** package and select one of the following:
   - If the connected has not been pushed to the distribution points, select **Distribute Content**.
– If the content exists on the distribution points, select **Update Distribution Points**.

**Note**
Anytime a config file is added to the BCU source folder, the package must be updated on the distribution points.

**Editing a task sequence to modify BIOS settings and disable or enable BitLocker**
The HP BIOSConfigUtility.exe requires a BIOS setting text file to perform configurations. The tool can also be used to set a BIOS Administrator password or to work with systems that have a password in place. This text file uses a specific syntax to ensure that it is properly recognized and used. Get this file by running the tool on an existing client (one that is to be managed) with the /GET option. The file can then be modified and applied to a similar client with the /SET option.

1. Right click the task sequence and select **Edit**.
2. At the top left of the task sequence Disable BitLocker, click **Add > New group**. Add this group to the beginning of the task.
3. Click **Add**, select **Disks** and then click **Disable BitLocker**.

**Note**
To use this task sequence step, the Windows operating system must support BitLocker.

4. Add another new group to the end of the task, called BitLocker Tasks.
5. Click **Add > General > Run Command Line**.

6. Rename this task **Set BIOS settings for BitLocker via BCU**.
7. Select the start this command line in a package box, and then select the **HP Client BIOS Configuration Utility** package.
8. Add this command line, where **810G2.txt** is the name of the configuration file in the BCU\config folder and **P@ssw0rd1234.bin** is the password file in the root of the BCU package source:
   ```
   RunBCU.cmd /nspwdfile:P@ssw0rd1234.bin /setconfig:"Config\810G2.txt"
   ```
This command line sets the BIOS password to the value in the P@ssw0rd.bin setting, enables TPM on next boot, bypasses the F1 prompt that is generally associated with activating the TPM, and prepares the BIOS settings for the operating system to manage the TPM.

**Note**
Most systems can use the same or a similar config file. If you have multiple config files for multiple systems and want to deploy a task sequence delivering the config files tasks to the right systems, you can use the If any SYSID statements. For instructions, see Configuring task sequence steps for your environment.

9. Click **Add > General > Restart Computer**.
   A. Set **Restart** to the currently installed operating system.
   B. Optionally, choose to notify the user.
10. Click **Add > Disk > Enable BitLocker**.
11. Enter the appropriate information on the BitLocker task.
12. The task is ready for deployment.
HP update deployment

Keeping the computers in a business up to date, with both the latest software and hardware updates, presents a number of problems, including time, bandwidth, and logistical issues. HP offers tools that help streamline the update process, reducing IT costs for small businesses and across an enterprise.

The method you select for your organization’s update depends on both on your existing infrastructure and the requirements you have for software deployment and updates. Consider the following deployment methods and how you can use them to support your deployment.

Deploying HP updates via HP Client Catalog and Microsoft SCCM 2012 or higher

HP highly recommends deploying HP updates via HP Client Catalog and SCCM. This method comprehensively assesses, deploys, and updates servers, client computers, and devices across physical, virtual, distributed, and mobile environments. SCCM is designed for large organizations and allows greater flexibility in customizing deployments of updates.

In addition, HP offers HP Client Catalog to streamline updates for HP systems within a SCCM infrastructure; HP Client Catalog contains software driver and patch information for desktops, notebooks, and workstations. It provides detailed platform information for software updates to target appropriate client systems within the managed enterprise.

Figure 1. Third-party update process using SCCM

1. Administrator downloads and imports the HP Client Catalog into the publishing tool.
2. Administrator publishes flagged updates to the SMS site server.
3. Target devices get policies to scan for updates.
4. Target devices download and scan for update compliance. The scan engine may query WMI for applicability.
5. Target devices send the compliance information back to the site database.

1. Administrator selects and approves HP updates for distribution.
2. The update packages are downloaded to the distribution point.
3. Target devices get deployment policies.
4. The update packages are downloaded and installed.
5. Target devices are rescanned for compliance and the information is sent back to site database.
Configuration Manager

Configuration Manager uses Windows Server Update Services (WSUS) and the System Center Updates Publisher (SCUP) for the software update process. SCUP allows an IT administrator to import and select custom software updates to publish to WSUS.

The Configuration Manager custom update process includes three phases:

- Importing and publishing third party updates
  HP customers can configure the import list in SCUP to reference the link to the catalog on the HP FTP site and import it into SCUP. The administrator can then select updates to publish to WSUS. Configuration Manager synchronizes with WSUS, either on schedule or on demand, to insert the software update metadata into the Configuration Manager Software Update Point server role. When the synchronization is complete, a site-wide machine policy is created to allow managed systems to retrieve and initiate a scan for software update compliance.

- Scanning clients for update compliance
  When a managed system receives the machine policy, a compliance scan is scheduled. The Windows Update Agent (WUA) connects to the WSUS server, retrieves the list of updates, and scans the managed system against the applicability and installed rules of each update. The Configuration Manager Software Update Client Agents send compliance information back to the site server. Based on the compliance status, the administrator can see which update are needed by managed systems and can then decide which updates to distribute.

- Deploying updates
  The administrator creates deployments and deployment packages to distribute the selected updates. When a collection of targeted devices receives a new deployment from the management point, the clients download the software updates from a distribution point that has a deployment package containing the necessary software update binaries. The binaries are then installed on the clients and the compliance status is reported to the site server.

Importing and publishing third-party updates

After installing and configuring the Configuring Manager site server, WSUS, and SCUP, you can use the following steps to import the HP Client Catalog.

1. Download the HP Client Catalog for Microsoft System Center Products at the following link and save it to your primary site server or a system running the SCUP:
2. Select Start > All Programs > System Center Updates Publisher > System Center Updates Publisher 2011.
3. Click Import, and then select Browse to browse to the location of the HP Client Update catalog cab file.
4. Follow the on-screen instruction to complete the importation.

*Note*
There might be a security prompt to accept software update binaries signed by HP Inc. The option *Always accept content from “HPInc.”* allows the administrator to publish multiple HP updates without having to accept each individually. Select the appropriate option, and then select *Accept.*

5. When the importation is complete, the Confirm dialog appears. Select *Close.*

6. The SCUP windows displays the HP Business Clients under *All Software Updates.* Click *HP Business Clients* to view all drivers and the categories.
Publishing HP updates to WSUS

1. Select your updates. Right-click the updates, and then click **Publish**.
   – or –
   Click the **Publish** button.

2. Select the appropriate publishing option.

3. Follow the on-screen instructions.
Synchronizing software updates from WSUS to Configuration Manager 2012

1. In the Configuration Manager console, select **Software Library > Application Management > Software Updates > All Software Updates**.

2. Right-click **All Software Updates**, and then select **Synchronize Software Updates**.

3. The synchronization process is initiated and might take a few minutes to complete. There is no visual indication that the process has completed.

   **Note**
   Open `SMS_WSUS_SYNC_MANAGER` for details of the sync process.

4. After the synchronization process has completed, follow the steps in Deploying an HP software update from Configuration Manager to deploy an HP update.

**Deploying an HP software update from Configuration Manager**

1. In the Configuration Manager console, select **Software Library > Application Management > Software Updates > All Software Updates**.

2. Right-click an update to be distributed, and then select **Deploy**.

3. Enter an appropriate name, and then select **Browse** and browse to select the collection to target for this update. If you wish to create a collection for HP devices, see Deploying HP updates via HP SSM and HP SDM.

4. Follow the on-screen instructions to complete the deployment process.

   **Note**
The white paper [HP Client Updates Catalog for Microsoft System Center Products](#) provides details on the setup and custom update process, explains the benefits of using this option, and provides additional resources for importing the catalog into the SCCM and deploying HP updates to HP systems.
Deploying HP updates using HP SDM and HP SSM

HP SDM is a free tool that allows you to download HP updates by selecting platforms and an operating system.

HP SSM is a free utility that helps streamline the mass deployment of system software updates to target devices. HP SSM reduces the complexity of system software management by delivering the following capabilities:

- Deploying system software updates (for example, drivers and BIOS) from a centralized file store to multiple target devices, simultaneously and automatically
- Deploying customer-created update packages
- Logging the changes made to each computer

Creating an SSM batch file

To create an SSM batch file for use either with SCCM or with no management console:

1. Open Notepad.
2. Enter the following syntax into a new text document:

```
Echo off
Net use \\
<SoftpaqServerHostname>\SSMFS /u:<domain>\<account> <password>
Echo.CD=%CD%
Pushd %~dp0
ssm.exe \\
<SoftpaqServerHostname>\SSMFS /install /a /edebug /noreboot /log:\<SoftpaqServerHostname>\Logs\Popd
```

Example:
```
Echo off
Net use \Win81x64\SSMFS /u:example\administrator P@ssw0rd
Echo.CD=%CD%
Pushd %~dp0
ssm.exe \Win81x64\SSMFS /install /a /edebug /noreboot /log:\Win81x64\SSMLogs\Popd
```

**Note**
The /edebug switch is not necessary, but is recommended during testing because it creates log files in your log share. It can be removed for production.

To upgrade a BIOS SoftPaq, use the following syntax (replace <filepath> with the path to the .bin file containing the password):
```
ssm.exe \\
<SoftpaqServerHostname>\SSFS /install /a /edebug /noreboot /cpwdfile: "<filepath>" /log:\<SoftpaqServerHostname>\Logs\Popd
```

Ensure that <SoftpaqServerHostname>\Logs has the Write permission.

3. Click File > Save As.
4. Under Save as type, select All Files, and save the file to a temporary location as SSM.bat.
Deploying HP updates using HP SDM and HP SSM with SCCM

A simple way to automate software updates is by using HP SDM and HP SSM in conjunction with SCCM. This provides you with a complete solution to manage your HP computers.

The key features and benefits include the following:

- **Client information**—Allows you to retrieve the hardware and software inventory of HP computers. You can generate numerous reports to help track down the hardware or software currently installed on your system devices.

- **SoftPaq Deployment**—Deploys SoftPaqs (software support files, such as BIOS and driver updates) from a central location to the devices that need them.

Configuring the package directory

1. On the SCCM server, create a folder to hold the SSM package on a network share. In this example, c:\SSMPackage or \SCCM\SSMPackage is the directory used. Use the share location for your environment.

2. If you haven’t already, create an SSM batch file (SSM.bat) as described in Creating an SSM batch file.

3. Copy SSM.bat, SSM.exe, and SSM.cab into this directory.

Creating an SCCM package to deploy SSM

1. In the Configuration Manager console, click **Software Library**.

2. Expand **Application Management**.

3. Right-click the **Packages** folder, and then select **Create Package**.

4. Name the package and enter any additional information on the first page of the wizard, and then click **Next**.

Note
Make sure you that select the source file location where you saved SSM.exe, SSM.cab, and the SSM.bat script. Do not select the shared folder containing the SoftPaqs.

5. Verify that the default Standard Program is selected, and then click Next.
6. Enter the information on the program in this package. The information boxed in red in the following figure is especially important.
   A. In the Name field, enter SSM.bat.
   B. In the Command line field, select Browse, and then select SSM.bat.

   **Note**
   To select SSM.bat, be sure to change the file type from exe files to all files.

   C. Under Run, select Normal.
   D. Under Program can run, select Whether or not a user is logged on.
   E. Under Drive mode, select Runs with UNC name.

7. Enter the Estimated disk space and Maximum allowed run time (minutes).
8. Click **Next**. There is a notification when the wizard is completed successfully.

![The Create Package and Program Wizard completed successfully]

*Editing the SSM.bat program for distribution*

1. In the Software Library, select the **SSM Script** package.

2. Click the **Programs** tab, and then right-click the **SSM.bat** program. Select **Properties**.

3. Select **Allow this program to be installed from the Install Package task sequence without begin deployed**.

4. Click **Apply**, and then click **OK**.

*Distributing the SSM Script package*

1. Right-click the **SSM Script** package and select **Distribute Content**.
2. Select the distribution point.

3. There is a notification when the content is distributed successfully.

Adding an HP SSM application to a task sequence for HP updates deployment

The following procedure assumes that the target device already has a full operating system, the SCCM client agent, and necessary drivers, such as network drivers, installed.

An SCCM-managed device should have the client agent installed. See the following figure.

1. Create a task sequence.
2. Right-click the newly created task sequence, and then select **Edit**.
3. Click **Add > General > Install Package**.
4. Select the HP SSM package created in Creating an SSM package and name this step appropriately.

5. Click **Apply**, and then click **OK** to close the task sequence.
   
The task sequence is ready to be deployed.

**Note**
HP recommends selecting the **Download all content locally before starting task sequence** option for deployment.

---

Adding an HP SSM application to an operating-system-deployment task sequence for HP updates deployment
If you wish to use HP SSM to install additional SoftPaq with a bare-metal deployment, the task sequence will look similar to the following figure.
Note
HP recommends listing the SSM package task after the setup operating system task. See Creating a package and deploying .NET Framework 4.5.

Creating a package and deploying .NET Framework 4.5 (optional)
It is not uncommon for a SoftPaq or application to need a different version of .NET Framework. If necessary to ensure maximum compatibility, deploy .NET 4.5 using this task. HP recommends inserting this task before the SSM task.

To create a .NET framework:
1. Download the .NET Framework 4.5 offline installer from Microsoft at http://go.microsoft.com/fwlink/?LinkId=225702.
2. Copy this download to its own folder, either on the SCCM network share or a local folder.
3. Go to https://msdn.microsoft.com and use the website’s search function to find and open the article .NET Framework Deployment Guide for Administrators.
4. Complete the steps under the article section Create a package and program for the .NET Framework redistributable package.

To distribute the .NET framework 4.5 package:
1. Right click the newly created .NET framework 4.5 package and select Distribute Content.
2. Select the distribution point.
3. There is a notification when the distribution completes successfully.

Deploying HP updates using HP SDM and HP SSM with no management console
This method is useful for small companies that do not have SCCM infrastructure or another management console setup.

If you haven’t already, create an SSM batch file (SSM.bat) as described in Creating an SSM batch file, and then copy the batch file to a path on the local hard drive of the target device (such as c:\Script\SSM.bat).
To create a scheduled task:

1. On the targeted device, select **Control Panel > Administrative Tools > Task Scheduler**.
2. Expand **Task Scheduler Library**.
3. Right-click **Task Scheduler Library**, and then click **Create Basic Task**.
4. In the **Name** and **Description** boxes, enter the appropriate name and description.
5. Select the appropriate schedule: **Daily**, **Weekly**, **Monthly**, **One time** (and then enter the time to start the task), **When the computer starts**, **When I log on**, or **When a specific event is logged**.
6. Select the action for the task to perform. For example, select **Start a program**.
7. Browse to the SSM.bat file.
8. Select **Open the Properties dialog for this task when I click Finish** to modify the settings.
9. Click **Finish**. The properties screen is displayed.
10. On each tab, modify the settings as desired.
11. Click **OK** to close.

**Appendix A: Installing the HP MIK for Configuration Manager 2012 R2 or higher**

1. Go to [http://ftp.hp.com/pub/caps-softpaq/cmit/HP_CIKHPMIK.html](http://ftp.hp.com/pub/caps-softpaq/cmit/HP_CIKHPMIK.html) and download the SoftPaq for the latest version of HP MIK for Configuration Manager 2012 R2 or higher to either the primary site server or a system running the Configuration Manager console.
2. Double-click the .exe file and follow the on-screen instructions to complete the installation.
Appendix B: Using HP SDM

HP SDM is a powerful tool used to locate and download and manage drivers specific to HP. HP SDM can make driver management easier.

Installing and setting up HP SDM

1. On your SCCM server or any system within the same network, download the HP SDM installer at http://ftp.hp.com/pub/caps-softpaq/HP_SDM_Setup.exe.
2. Create a new shared folder for your downloaded SoftPaqs and the HP SSM files. For example, if installing HP SDM on a Win81x64 device, you might create the folder \Win81x64\SSMFS. This path is used in all figures for this procedure.
3. Run the installer.
4. When prompted, select Show software for all supported models. If already in HP SDM, select Show All Products.
5. Go to Tools > Configuration Options.
6. Click the Download tab and change the location to the SSM share created earlier.
7. On the OS Filter tab, select any operating systems that you want to support.
8. On the Language Filter tab, select any language versions that you want to support.
9. Click OK.

Downloading required SoftPaqs

You can use HP SDM to download SoftPaqs for updating target devices.

1. After the Configuration Options have been set, in the Product Catalog, verify that HP SDM has Show All Products selected.
2. Select your platform and expand the product tree to the operating system.

3. Click **Find Available SoftPaqs**.

**Note**
Only SoftPaqs that are marked as HP SSM compliant are added to the HP SSM database. To help with the selection process, you can have HP SDM select all HP SSM-compliant SoftPaqs by selecting **Select SoftPaqs > Auto-Installable (SSM-Compliant)**.
4. Click **Show Latest SoftPaqs**.

5. Select **Download Only**.

6. When the download finishes, click **Update CVA Files** to download the latest CVA files.

7. To quickly view a SoftPaq CVA file, right-click the downloaded SoftPaq and select **View SoftPaq CVA**.

8. To quickly review the contents of the file store, in the Download SoftPaqs window, select **Explore**.
To use HP SDM to download an HP driver pack for operating system deployment:

1. Repeat steps 1–4 of the previous procedure to show the latest SoftPaqs.
2. Select the driver pack for your system.

```
[Check box for selected driver pack]
```

3. When the download finishes, right-click the downloaded SoftPaq and select **View SoftPaq Release Notes**.

4. The SoftPaq release notes provide necessary information about the downloaded SoftPaq. In this example, there are couple of sections of information to concentrate on.

   - Supported hardware models
     - HP EliteBook 840 G2 Notebook PC
     - HP EliteBook 740 G2 Notebook PC
     - HP EliteBook 850 G2 Notebook PC
     - HP EliteBook 750 G2 Notebook PC
     - HP ZBook 14 G2 Mobile Workstation
     - HP ZBook 15u G2 Mobile Workstation
     - HP EliteBook 820 G2 Notebook PC
     - HP EliteBook 720 G2 Notebook PC

   - Drivers that are provided in the SoftPaq
     - Intel I217LM/V and I218LM Gigabit Ethernet Driver, version 19.5
     - Intel 7260/3160 Wireless LAN Driver, version 17.13.0.9
     - Synaptics Mouse Driver, version 18.1.37.3
     - Alcor Micro Smart Card Reader Driver, version 1.7.42.0
     - Intel Video Driver and Control Panel, version 15.36.3995
     - AMD HG Video Driver, version 14.301.1002.1004
     - Synaptics WBF Fingerprint Driver, version 4.5.265.0
     - Realtek USB and PCIe Media Card Reader Drivers, version 6.3.273.49
     - NXP NFC NPC100 Proximity Drivers, version 3.7650.10422.30
     - Intel Rapid Storage Technology Driver (64-bit), version 13.2.0.1016
     - Intel Management Engine Components Driver, version 10.0.30.1072
     - Intel Chipset Installation Utility, version 10 10.0.22
     - HP Universal Camera Driver, version 2014 1.12
     - HP 3D DriveGuard, version 6.0.23.1
     - Realtek HD Audio Driver, version 2014 6.0.1.7383
     - HP Wireless Button Driver, version 1.1.2.1
     - HP lt4211 Gobi 4G Drivers, version 1.1.0.39
     - HP lt4211 Gobi 4G Drivers, version 1.1.0.39
     - HP lt4112 Gobi 4G Drivers, version 12.1803.5.2
     - HP hs3110/hs3114 Mobile Broadband Drivers, version 12.1803.2.4

   - Drivers that are not provided in the SoftPaq,
NOTES:
- A Bluetooth driver is not included. Please visit the product download page on www.hp.com to install the Bluetooth driver.
- Verify that the Microsoft SCCM environment has all cumulative updates installed. Issue may be encountered if the environment is not up to date.
- A fingerprint driver is included for Windows security authentication only. For full use of HP Client Security Manager, download and install the full setup package found on the products software download page.

HP recommends downloading the additional driver SoftPaqs referenced in the CVA file or release notes, such as Bluetooth, fingerprint reader, and any others. HP also recommends downloading any BIOS updates for the systems you include in your task.

Appendix C: Installing and configuring HP SSM

HP SSM is a powerful way to handle drivers that must be installed as full executables. HP SSM, when run on a device system, searches a network share to find available executables and then install them silently on the client system. By using HP SSM, an administrator can execute a single application on the target device to install several different SoftPaqs in an imaging task. In addition, HP SSM uses the CVA files for SoftPaqs and WMI queries on the devices to figure out exactly which SoftPaqs should be installed on a given system. This allows an administrator to support a broad range of HP systems with a single task-sequencing steps.

Because of this flexibility, HP SSM is the preferred method for handling .exe based drivers in an imaging task. Additionally, HP SSM is an excellent way to handle graphics drivers for your workstation deployments, because graphics drivers that HP releases are HP SSM compliant and often work better with their application component installed.

Installing HP SSM

2. Navigate to <C:\Program Files (x86)\Hewlett-Packard\System Software Manager>.
3. Copy SSM.exe and ssm.cab to the shared folder where you downloaded the SoftPaqs using HP SDM.
Running SSM.exe in Administrative Mode
1. After you install HP SSM, double-click SSM.exe from the shared folder containing the downloaded SoftPaqs.
2. Accept the licensing agreement.
3. Verify that the share information is properly autopopulated.
4. Configure the advanced client options.

Note
There is a second share called SSMLogs for logging.
5. Optionally, create an encrypted BIOS password file. A setup password step is required if the device system has a BIOS setup password and the BIOS needs to be updated. Select **Launch** to display the HPQPswd dialog and create an encrypted password.

   ![HP System Software Manager](image1.png)

   **A.** Enter the **Password to be encrypted**. For example, P@ssw0rd1234.

   **B.** Select **Browse**, and then browse to the local HP SSM file store and save the encrypted password bin file.

   **Note**
   You can name the password bin file anything.
6. Select **Browse**, and then browse to the P@ssw0rd1234.bin file you just created.

7. Verify the operations to be performed.

**Note**
The password is not set via SSM, but via HP BIOS Configuration Utility tool in the SCCM task sequence.

8. Select **Check ftp.hp.com for CVA file updates**, and then select **Build Database**.

9. When the **Building database** bar is completely green, click **Finish**.

**Note**
The target devices need access to the file store containing the SoftPaqs to run HP SSM properly. HP SSM tries to create the share automatically; however, this might not work in certain cases, such as domain settings or when the share is located on another computer. You might need to share and/or change the settings of the target folder manually.

Each time a new version of HP SSM is installed or new SoftPaqs, directories, or subdirectories are added or deleted from the File Store, the database must be rebuilt.

Appendix D: Configuring the Set BIOS Configuration task step

The Set BIOS Configuration (Input File) task step allows you to configure BIOS settings on platforms managed by HP. This Run Command Line task uses the HP Client BIOS Configuration Utility package.

Figure 2. HP Client Hardware Configuration Task

Use the following command line to run this task-sequence step:
RunBCU.cmd <parameters to pass to BCU>

This action applies the BIOS settings specified in the selected REPSET file. It can also execute specified command-line options. The batch file calls the appropriate version of BCU, depending on the architecture of the current operating system.

An example REPSET file is included with the package. It is located in the Config folder of the package source folder and named BCUSettingExampleOnly.REPSET. If this REPSET file is used in this task step, enter the command line as follows:

RunBCU.cmd /setconfig:"Config\BCUSettingExampleOnly.REPSET" /npwdfile:"P@ssw0rd1234.bin"

**Note**
In the previous example, the P@ssw0rd1234.bin file is in the same location of the repset file.

HP recommends saving the REPSET file in the source folder or subfolder of the package so that it can be easily referenced in the command line.

**Adding and editing configuration files**

To add a new configuration file, do the following:

1. Get the configuration file from the target device.
2. Modify the file. Set the values, and then remove settings and values from the configuration file that are not required to be applied through this configuration.
3. Find the package source folder location of BCU. The package is typically located in the Software Library. Select **Overview** > **Application Management** > **Packages** > **HP Client Support Packages**.
4. Select the source folder location and copy the REPSET file to the folder.
5. Update the distribution points so that the REPSET file is made available to the task sequence.

**Notes and warnings**

Be aware of the following when using this task sequence step:

- If you make changes or add a configuration file to the package folder, be sure to update the HP Client BIOS Configuration Utility package to the distribution points to ensure that the new configuration files are available for the task sequence.
- Reboot the target device to be sure that all BIOS setting changes take effect.
  
  To do this automatically, add a **Restart Computer** task to the task sequence.

- Changing certain BIOS settings might cause a task sequence to fail to complete. Be sure to test the desired BIOS configuration file before deploying the task sequence.
- Certain characters used in BIOS passwords might require special escaping to work properly; for more information, see the **HP BIOS Configuration Utility User Guide** included with the CIK.

**Appendix E: Creating an SCCM device collection for HP devices**

**Enabling classes in the target device settings**

1. In the Configuration Manager console, select **Administration** > **Overview** > **Client Settings**.
2. Right-click **Default Client Settings** and select **Properties**.
3. Select **Hardware Inventory**, and then click **Set Classes**.

4. Select the appropriate classes
5. Click **OK** to close.

**Creating a collection and building a query**

1. In the Configuration Manager console, select **Assets and Compliance > Overview > Device Collection**.
2. Right-click **Device Collection** and select **Create Device Collection**.
3. Enter an appropriate name (such as HP Inc.).
4. Click **Browse**, select **Limiting Collection**, and then click **Next**.
5. Click **Add Rule**, and then select **Query Rule**.
6. The Query Rule Properties screen is displayed. Enter an appropriate name, and then click **Edit Query Statement**.
7. A new screen is displayed. On the Criteria tab, click the New icon.

8. On the Criterion Properties screen, under Criterion Type, select Simple value.

9. Click Select the Attribute, and then enter the following:
   A. Under Attribute class, select BaseBoard.
   B. Under Alias as, select <No Alias>.
   C. Under Attribute, select Manufacturer.

10. Select Value, enter the appropriate information, and then select OK.
11. Click **Show Query Language** to view the actual query language. This can be useful for scripting, because much of this can be done via PowerShell.

By creating this query, you can deploy an operating system, an update, or software package to a custom HP Inc. (or whatever name you entered) limiting collection.
For more information

For the latest downloads and documentation for Client Management Solutions, go to http://www.hp.com/go/clientmanagement. This includes the following products:

- HP BIOS Configuration Utility (BCU)
- HP Client Integration Kit (CIK)
- HP SoftPaq Download Manager (SDM)
- HP System Software Manager (SSM)
- Driver packs

To download the latest version of HP Client Updates Catalog, go to ftp://ftp.hp.com/pub/softlib/software/sms_catalog/HpCatalogForSms.latest.cab.

To read more about SCCM, go to http://www.microsoft.com/systemcenter.

Sign up for updates
hp.com/go/getupdated