Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
HP.com home
Technical documentation

HP-UX Java Patch Information

  »

Java on HP-UX documentation

Content starts here
HP-UX patches required for Java™

Always check this page for the latest patch information, as the page is updated frequently whenever new quality packs are issued or new versions of HP-UX or Java are available.

Patches should be installed before you install the Java software. Some patches are absolutely required to run Java, others are recommended for optimum performance. HP recommends that you install all the patches shown for your system configuration.

Determining which patches to install

  1. Determine the version of HP-UX you are running, which selects a row in the table.
  2. Determine the Java version you are using, which selects a column in the row.
  3. Determine which Quality Pack (if any) you have installed on your system. If you have no Quality Pack installed, use the last entry "Base <os-version>" in the table cell. Note: If you have no Quality Packs installed, HP recommends that you first install the most recent Quality Pack from the HP Support Center at http://www.hp.com/go/hpsc. (You need an HP_UX support contract to obtain quality packs and patches).
  4. Click the link in the table cell for your HP-UX version, Java version, and installed Quality Pack, which will display the additional Java required or recommended patches that are not installed by the Quality Pack. (The numbers in parentheses indicate the number of patches.) If no additional patches are required, you will see the text "(none)".

  Java 1.3 * Java 1.4 Java 5.0 Java 6.0 Java 7.0 ** Java 8.0 **
HP-UX
11.00 PA
March '04 (2)
Sept '03 (4)
March '03 (5)
Sept '02 (7)
March '02 (8)
Sept '01 (13)
Base 11.00 (26)
March '04 (3)
Sept '03 (5)
March '03 (7)
Sept '02 (9)
March '02 (10)
Sept '01 (16)
Base 11.00 (31)
not supported
not supported
not supported
not supported
HP-UX
11.11 PA
(11i v1)
Dec '09 (none)
June '09 (none)
Dec '08 (none)
June '08 (none)
Dec '07 (none)
June '07 (none)
Dec '06 (none)
June '06 (1)
Sept '05 (1)
June '05 (1)
Dec '04 (1)
June '04 (3)
Dec '03 (4)
June '03 (4)
Dec '02 (6)
June '02 (8)
Dec '01 (19)
June '01 (26)
Base 11.11 (26)
Dec '09 (none)
June '09 (none)
Dec '08 (1)
June '08 (1)
Dec '07 (1)
June '07 (1)
Dec '06 (1)
June '06 (3)
Sept '05 (3)
June '05 (4)
Dec '04 (4)
June '04 (7)
Dec '03 (8)
June '03 (9)
Dec '02 (11)
June '02 (14)
Dec '01 (26)
June '01 (33)
Base 11.11 (33)
Dec '09 (none)
June '09 (none)
Dec '08 (1)
June '08 (1)
Dec '07 (1)
June '07 (1)
Dec '06 (1)
June '06 (3)
Sept '05 (3)
June '05 (4)
Dec '04 (4)
June '04 (7)
Dec '03 (8)
June '03 (9)
Dec '02 (11)
June '02 (14)
Dec '01 (26)
June '01 (33)
Base 11.11 (33)
Dec '09 (none)
June '09 (none)
Dec '08 (1)
June '08 (1)
Dec '07 (2)
June '07 (2)
Dec '06 (2)
June '06 (4)
Sept '05 (4)
June '05 (5)
Dec '04 (5)
June '04 (8)
Dec '03 (9)
June '03 (10)
Dec '02 (12)
June '02 (15)
Dec '01 (27)
June '01 (34)
Base 11.11 (34)
not supported
not supported
HP-UX
11.23 IA/PA
(11i v2)
Dec '10 (none)
June '10 (none)
Dec '09 (none)
June '09 (none)
Dec '08 (none)
June '08 (none)
Dec '07 (none)
June '07 (none)
March '07 (none)
Sept '06 (2)
June '06 (2)
March '06 (2)
Dec '05 (2)
May '05 (2)
Sept '04 (2)
March '04 (4)
Base 11.23 (4)
Dec '10 (1)
June '10 (1)
Dec '09 (1)
June '09 (1)
Dec '08 (1)
June '08 (1)
Dec '07 (1)
June '07 (2)
March '07 (2)
Sept '06 (4)
June '06 (4)
March '06 (4)
Dec '05 (4)
May '05 (4)
Sept '04 (4)
March '04 (6)
Base 11.23 (6)
Dec '10 (1)
June '10 (1)
Dec '09 (1)
June '09 (2)
Dec '08 (2)
June '08 (3)
Dec '07 (4)
June '07 (5)
March '07 (5)
Sept '06 (7)
June '06 (7)
March '06 (7)
Dec '05 (7)
May '05 (7)
Sept '04 (7)
March '04 (9)
Base 11.23 (9)
Dec '10 (2)
June '10 (2)
Dec '09 (2)
June '09 (3)
Dec '08 (3)
June '08 (4)
Dec '07 (5)
June '07 (6)
March '07 (6)
Sept '06 (8)
June '06 (8)
March '06 (8)
Dec '05 (8)
May '05 (8)
Sept '04 (8)
March '04 (10)
Base 11.23 (10)
Dec '10 (5)
June '10 (5)
Dec '09 (5)
June '09 (6)
Dec '08 (6)
June '08 (7)
Dec '07 (8)
June '07 (9)
March '07 (9)
Sept '06 (11)
June '06 (11)
March '06 (11)
Dec '05 (11)
May '05 (11)
Sept '04 (11)
March '04 (13)
Base 11.23 (13)
not supported
HP-UX
11.31 IA/PA
(11i v3)
not supported
March '14 (none)
Sept '13 (none)
March '13 (none)
Sept '12 (none)
March '12 (none)
Sept '11 (none)
March '11 (1)
Sept '10 (1)
March '10 (1)
Sept '09 (2)
March '09 (2)
Sept '08 (2)
March '08 (2)
Sept '07 (2)
Base 11.31 (2)
March '14 (none)
Sept '13 (none)
March '13 (none)
Sept '12 (none)
March '12 (none)
Sept '11 (none)
March '11 (1)
Sept '10 (1)
March '10 (1)
Sept '09 (2)
March '09 (2)
Sept '08 (3)
March '08 (4)
Sept '07 (4)
Base 11.31 (4)
March '14 (none)
Sept '13 (1)
March '13 (1)
Sept '12 (1)
March '12 (1)
Sept '11 (1)
March '11 (2)
Sept '10 (2)
March '10 (2)
Sept '09 (4)
March '09 (4)
Sept '08 (5)
March '08 (6)
Sept '07 (6)
Base 11.31 (6)
March '14 (none)
Sept '13 (1)
March '13 (1)
Sept '12 (4)
March '12 (4)
Sept '11 (5)
March '11 (6)
Sept '10 (6)
March '10 (6)
Sept '09 (7)
March '09 (7)
Sept '08 (8)
March '08 (9)
Sept '07 (9)
Base 11.31 (9)
March '14 (none)
Sept '13 (1)
March '13 (1)
Sept '12 (4)
March '12 (4)
Sept '11 (5)
March '11 (6)
Sept '10 (6)
March '10 (6)
Sept '09 (7)
March '09 (7)
Sept '08 (8)
March '08 (9)
Sept '07 (9)
Base 11.31 (9)

* Release not Supported

** Release Supported on IA only
Generated on Mon Oct 13 23:59:03 2014

Determining your HP-UX version

To determine which HP-UX version is running on your system, use the following command:

	uname -r

Determining your Java version

To find your Java version, assuming the directory where it is installed is in your PATH variable, run the following at the command prompt:

	java -version

If your Java JDK or JRE is installed in a non-default location, or if you have multiple versions installed on your system, run the following command:

	<java-home>/bin/java -version

Alternately, if you installed your Java JDK or JRE using SD (swinstall), you can run the following command:

	/usr/sbin/swlist | grep -i java

For more information on Java versions, refer to http://www.hp.com/go/hpux-java-docs

Determining which quality pack is installed

HP-UX Quality Pack bundles include all stable defect-fix patches for core HP-UX, graphics and networking drivers. To obtain the latest Quality Pack bundles for your version of HP-UX, go to http://www.hp.com/go/hpsc. (You need an HP_UX support contract to obtain quality packs and patches).

To determine which Quality Packs are installed on your system use the following command:

	/usr/sbin/swlist | grep -e QPK -e GOLD -e BUNDLE11i

If there are Quality Packs installed on your system, you will see bundle tags similar to the following in the output:

	QPK1100       B.11.00.64.4   Quality Pack for HP-UX 11.00, March 2004
	GOLDBASElli   B.11.11.0506.4 Base Patches for HP-UX 11i v1, June 2005
	BUNDLE11i     B.11.23.0409.3 Required Patch Bundle for HP-UX 11i v2 (B.11.23), September 2004

Java™ and all Java based trademarks and logos are trademarks or registered trademarks of Oracle America and/or its affiliates in the United States and other countries. Java™ compatible logo
Printable version
Privacy statement Using this site means you accept its terms
© 2014 Hewlett-Packard Development Company, L.P.